 Введение

Программа S-CloseInform

S-CloseInform обеспечивает надежное закрытие файлов на персональном компьютере.Закрытые файлы, не опасаясь их просмотра посторонними лицами, можно пересылать по открытым каналам (EMail).
Для удобства работы с большим количеством файлом при пересылке их по электронной почте и хранении, возможно использовать архивирование файлов. Архив также дополнительно может надежно закрываться программой, как обычный файл, т.е. закрытые файлы помещаются в архив, который также может быть закрыт одним из алгоритмов шифрования.
Закрытие информации осуществляется по выбору одним из семи наиболее стойких алгоритмов шифрования RC4, Blofhish,DES, GOST,Skipjach, TEA, Twofish, а также уникальным - ZMN "Замена". При этом информация может эффективно сжиматься. Использование сформированного пользователем уникального ключа или любого файла в качестве ключа, дополнительно повышает уровень защиты.
Файлы закрываются с помощью автоматически формируемой для каждого файла уникальной псевдослучайной последовательности.
Конфиденциальная информация хранится в закрытых ключом с паролем (только паролем) файлах. Эти файлы имеют заданные пользователем расширения. Для восстановления или закрытия файла достаточно его открыть в программе ("перетащить" мышкой нужный файл в программу) и ввести ключ и пароль (только пароль). Программа может работать с файлами, находящимися в папках, для этого необходимо открыть или переместить нужную папку в программу.
Возможно обрабатывать сколь угодно большие директории с вложенными папками, единственное ограничение - размер любого обрабатываемого файла не должен превышать размера оперативной памяти компьютера.
Для увеличения надежности закрытой информации от возможных ошибок (искажение случайное или преднамеренное закрытых файлов) дополнительно введен подсчет циклической суммы всех байт обрабатываемых файлов.

Copyright © 2006-2009 by S Y N. All rights reserved. EMail: closeinform@nm.ru


 Необходимые требования для работы с программой S-CloseInform

Необходимые требования для работы с программой S-CloseInform

S-CloseInform обладает следующими характеристиками:
Операционная система - Windows
Аппаратные требования к компьютеру
Для функционирования S-CloseInform необходим ПК со следующими минимальными характеристиками (относятся, прежде всего, к Windows 95):
· Процессор Intel Pentium 100 MHz.
· Оперативная память не менее самого большого закрываемого файла
· Свободное пространство на жестком диске не менее объема закрываемых файлов


 Работа с программой S-CloseInform

Работа с программой S-CloseInform

После успешной установки программы S-CloseInform запустите ее обычным образом (Меню) - Пуск > Программы > S-CloseInform > S-CloseInform.exe или с ярлыка программы, если при инсталяции его создали. В правой нижней части экрана (панель задач) появится значок S-CloseInform (Рис.1)

Рис. 1 Значок S-CloseInform

Управлять программой возможно из меню программы или при помощи появляющегося меню (рис.2) в правой нижней части экрана (панель задач) при двойном щелчке левой кнопкой мышки по значку S-CloseInform.

Рис. 2 Основная Панель программы

После запуска программы появится Основная панель программы, изображенная на Рис. 3.

Рис. 3 Основная Панель программы

На основной панели программы возможно:
- найти на компьютере определенные файлы или все файлы с заданными расширениями, указав параметры поиска, в соответствующих полях. По умолчанию стоит расширение закрываемых программой файлов - cli. Данное расширение можно изменить в панели "Параметры" на вкладке "Файл"; - для быстрого показа заданного расширения закрываемых файлов (после поиска файлов с другими расширениями), достаточно сделать двойной щелчок мышки в поле расширений;
- установка значения "только жесткие диски" - будут доступны для поиска только жесткие диски Вашего компьютера.

Для поиска файлов необходимо в поле "Имя файла" ввести имя и в поле "Расширение файла" расширение искомых файлов. Для поиска всех файлов по заданному расширению ввести в поле "Имя файла" значение - *, а в поле "Расширение файла" - расширение искомых файлов. Для поиска нажать кнопку "Поиск". Выдвинется слева панель отображения найденных файлов рис. 4

Рис. 4 Панель отображения найденных файлов

Для обработки (зашифровывание или расшифровывание) необходимых файлов отображаемых в списке - поставте галочки напротив их и нажмите кнопку "Обработать". В основной панели программы появится окно "Обработать выделенные файлы" рис. 5.

Рис. 5 Обработка файлов из левой панели программы

При наличие всех незакрытых файлов активна кнопка "закрыть незакрытые файлы. Соответственно при наличие всех закрытых файлов активна кнопка "открыть закрытые файлы". В случае наличия открытых и закрытых файлов - активны обе кнопки. После выбора кнопки нажать "ОК" . Появится окно ввода пароля для зашифрования рис. 6

Рис. 6 Окно ввода пароля для закрытия файлов

Пароль должен иметь не менее пяти неповторяющихся символов. Для контроля правильности пароля необходимо ввести пароль повторно.
При расшифровании появится окно рис. 7

Рис. 7 Окно ввода пароля для открытия файлов

Ввести пароль и ключ для открытия файлов.

Copyright © 2006-2009 by S Y N rights reserved. EMail: closeinform@nm.ru


 Установка параметров S-CloseInform

Работа с программой S-CloseInform

Для установки параметров необходимо на основной панели нажать кнопку "Парам." или ссылку "Установка параметров", плавно появится окно (Рис.1)

Внимание!
Параметры программы сохраняются при последующих запусках только в зарегистрированной программе.

Рис.1 Окно установки параметров программы (панель "Общие параметры")

Окно установки параметров состоит из пяти вкладок:
1. Общие параметры
Отметьте необходимые поля:
- использовать только пароль - шифрование и дешифрование будет осуществляться с использованием одного пароля без ключа;
- запускать при старте ОС - программа будет автоматически загружаться при старте операционной системы Windows:
- включить звуковые эффекты - события в программе будут сопровождаться заданными звуковыми эффектами;
- показывать файлы в окнах программы в сокращенном виде;
- обрабатывать папку включая подкаталоги - при загрузке папки в программу будут обрабатываться файлы в каталогах загруженной папки;
- после открытия файла в программе сразу предлагать обработать файл.
Сервер обновлений программы. Меняется в случае изменения сервера обновлений.

2. Формирование ключа (рис.2)

Рис.2 Панель формирования ключа

Cформируйте свой уникальный ключ для чего на вкладке "Ключ" выберите необходимую длину ключа и нажмите кнопку "Пуск"
После чего перемещайте мышку по панели до полного создания ключа. Сохраните полученный ключ на любом съемном носителе информации и создайте копию созданного ключа простым копированием файла ключа на другой носитель. Уберите ключи в надежное место.

3. Выбор файлов звуковых эффектов (рис.3)

Рис.3 Панель выбора звуков событий

В закладке "Звук" выберите действие с программой и укажите соответствующий этому звуковой файл нажав кнопку "Обзор"

4. Установка метода шифрования информации (рис.4)

Рис.4 Панель выбора метода шифрования

Отметьте необходимые поля соответствующие выбранному методу шифрования.
Начиная с версии 2.2.0 введен новый метод закрытия информации ZMN "Замена", который основан на алгоритме RC4 и позволяет дополнительно кодировать символы с помощью встроенных таблиц (всего 256 таблиц) или вводимой пользователем уникальной кодовой таблицы. Для просмотра или коррекции кодовых таблиц необходимо щелкнуть мышкой по надписи "Таблица замены символов". Откроется окно с предложением о смене номеров символов кодовой таблицы. рис.5

Рис.5 Окно с вопросом о смене символов замены

Нажать - ОК, появится окно (рис.6)

Рис.6 Окно соответствия заменяемых номеров символов

После изменения таблицы нажать - ОК. В случае повторного использования номера заменяемого символа будет выдано сообщение о повторе. Для устранения проблемы нажать - ОК и в таблице заменить повторяющийся номер символа. Измененная таблица при последующих запусках программы не сохраняется.

5. Параметры обрабатываемого файла (рис.7)

Рис.7 Панель выбора параметров обрабатываемых файлов

- желаемое расширение закрываемых файлов, по умолдчанию - сli;
- количество первых символов имени закрываемого файла , по умолчанию - 3. В случае повторений имени закрытых файлов к новому имени добавляется единица, например был файл tex0.cli, при его повторе будет tex1.cli;
- скрывать закрываемый файл (файлы будут иметь атрибут скрытый;
- показ обработки всех файлов, будут отображаться в панели показа файлов процесс обработки
- степень сжатия файла (чем больше сжатие, тем медленнее обработка файлов).


 Защита программой S-CloseInform конфиденциальных данных

Закрытие-открытие информации программой S-CloseInform

Работать с программой S-CloseInform очень просто.
Запустить программу S-CloseInform.
Установить в панели управления необходимые параметры управления программой.
Открыть файл в программе можно несколькими способами:
Открытие и закрытие файла
1. Нажать на иконку "Открыть" и выбрать необходимый файл или папку (директорию).
2. Перетащить мышкой файл или папку в основную панель программы.
Возможно открытие в программе сразу нескольких файлов или целых директорий (папок). После получения файлов программа отобразит их в левой панели. Для закрытия файла достаточно по нему дважды щелкнуть мышкой. Для закрытия всех выбранных файлов - нажать кнопку "Обработать" на левой панели. Появится окно для ввода пароля и ключа (если не установлена галочка - "использовать только пароль"). Пароль вводится для проверки два раза, причем он не должен состоять из одинаковых символов и не должен быть меньше пяти символов. Программа начнет процесс закрытия файла (рис.1)

Рис. 1 Шифрование

При открытии файла с расширением соответствующим закрытому файла (по умолчанию расширение - cli), появится окно одиночного ввода пароля для открытия файла и ключа если не установлена галочка - "использовать только пароль". Начнется процесс дешифрования файла (рис.2)

Рис. 2 Дешифрование

3. Перетаскиваете или открываете в программе S-CloseInform папку и выбираете действия с файлами этой папки (рис. 3)

Рис. 3 Выбор закрытия или открытия всех файлов

При двойном щелчке мышкой по файлу в панели отображения файлов можно обработать одиночные файлы.

Только открытие закрытого файла
4. Находите с помощью встроенного поисковика по расширению закрытые файлы и кликаете по найденному файлу двойным щелчком мышки.
5. Кликаете двойным щелчком мышки непосредственно по иконке закрытого файла. В этом случае программа S-CloseInform запускается автоматически.

Примечание: в этом случае происходит сокращение длины имени открываемого файла (до 8 символов), поэтому данный способ применять не рекомендуется.

При открытии файлов возможно появление сообщения об неправильно введеном пароле или ключе. В этом случае необходимо внимательно проверить и ввести данные для открытия файлов. Для одиночного открытия файла необходимо двойным щелчком кликнуть мышкой по файлу в панели отображения файлов.

Процессы закрытия и открытия возможно остановить, нажав кнопку "Отмена", при этом обработка текущего файла будет закончена и программа вернется в исходное состояние.

Программа эффективно сжимает файлы (в панели управления выбирается степень сжатия на вкладке "Файл") и закрывает по одному из выбранных алгоритмов.
Закрытый ключ формируется автоматически из вводимого пользователем ключа и пароля.
Процес закрытия-открытия файлов отображается индикатором прогресса.


 Cоздание архива файлов

Создание и работа с архивами файлов

Программа позволяет создавать архивы из выбранных файлов. Это особенно удобно при отсылке по электронной почте большого количества файлов.
Для создания архива (одного файла с расширением RJT) выберите файлы в левой панели (поставте галочки напротив необходимых файлов или выберите все файлы поставив галочку - "Все").
Нажмите кнопку - " --> Создать архив", далее укажите папку и имя создаваемого архива.

Для извлечения файлов из архива необходимо открыть (перетащить) файл архива в программе. В левой панели отобразятся все файлы архива.

Созданный архив возможно закрыть как обычный файл, для этого файл архива необходимо открыть (перетащить) в программу в которой выдвинута левая панель выбора файлов. В противном случае архив будет просто разархивирован.


 Техническая поддержка программы

Техническая поддержка программы

Получить техническую поддержку S-CloseInform, а также комментарии и отзывы по различным вопросам использования S-CloseInform, в том числе замечания по программному обеспечению и документации направляйте по EMail: closeinform@nm.ru
Подробная информация, новые версии программы можно получить на сайте: http://closeinform.nm.ru


 Лицензия

Лицензионное соглашение

Изложенный ниже документ, является лицензионным соглашением между автором-владельцем программы (S-CloseInform) и пользователем.
Лицензионное соглашение действует только на данную версию программы.
S-CloseInform распространяется по принципу freeware (бесплатно).

Незарегистрированный пользователь имеет право:
- Распространять программу только бесплатно в одном инсталляционном файле, не внося в нее изменений;
- Перевести программу на отсутствующий в ней язык;
- Распространять перевод программы только бесплатно.

Зарегистрированный пользователь имеет право:
- Использовать программу без автоматической загрузки сайта разработчика программы;
- Использовать программу неограниченное количество времени и запусков;
- Распространять программу только бесплатно в одном инсталляционном файле, не внося в нее изменений;
- Перевести программу на отсутствующий в ней язык;
- Распространять перевод программы только бесплатно;
- Получать техническую поддержку и бесплатные обновления программы ветки 2.x;
- Использовать поочередно несколько копий программы, без предоставления возможности использования программы другим физическим и юридическим лицам.

Запрещается:
- Вносить изменения в код программы, в ее сообщения и прилагающиеся к ней файлы, за исключением перевода;
- Дизассемблировать и декомпилировать программу;
- Передавать, распространять зарегистрированную программу;
- Использовать или распространять отдельные части программы;
- Переводить программу, кроме как описанным способом;
- Использовать программу иначе, чем описано в данном лицензионном соглашении;
- Распространять программу вместе с программами для взлома;
- Запрещается использовать регистрационный ключ, полученный не от официальных дилеров и авторов;
- Нарушать описанные выше правила. Если пользователь нарушает описанные выше правила, то он обязан прекратить использование программой и стереть ее со всех своих запоминающих устройств. Если принципы распространения, эксплуатации или регистрации противоречат законам местности, в которой проживает пользователь, то он обязан прекратить использование программой и стереть ее со всех своих запоминающих устройств..

Предупреждение:
автор программы не несет ответственности за какие-либо действия и последствия связанные с использованием данной программы.


 Удаление программы S-CloseInform

Удаление программы S-CloseInform

В отдельных случаях Вам может потребоваться удаление (деинсталяция) программы S-CloseInform, для этого:
- завершите работу с S-CloseInform (если программа в этот момент активирована).
- кликните - Пуск > Настройка > Панель Управления. В открывшемся меню дважды кликните элемент Установка и удаление программ. На экране появится список программ, установленных в данной операционной системе. Выберите в этом списке S-CloseInform и кликните Заменить/Удалить.
После этого система запросит подтверждение на удаление S-CloseInform.


 Введение Безопасность

Безопасность Вашей информации на компьютере

Утечка информации на Вашем компьютере может стать причиной беды.
Программа S-CloseInform поможет защитить конфиденциальную информацию, закрыв и сжав ее. Восстановить информацию или ее часть без ключа и пароля практически невозможно.

Надежность длины ключа
От длины ключа и его уникальности зависит стойкость применяемого метода шифрования.
Ключ закрытия должен генерироваться по случайному закону. В программе реализован генератор по настоящему вырабатывающий случайные числа. При создании ключа достаточно двигать курсором мышки по панели программы генерации ключа в произвольном порядке до тех пор, пока ключ не будет создан.
Замедление при работе с шифрованными файлами
S-CloseInform использует оптимизированные по скорости алгоритмы закрытия и сжатия. Наиболее быстрым является алгоритм - ZMN "Замена", наиболее медленным алгоритм - TEA. Незначительное замедление работы зависит от обьема обрабатываемых файлов, оперативной памяти и процессора вашего компьютера.


 Cмена ключа и пароля

Замена ключа и пароля закрытого файла

Для повышения безопасности информации необходимо периодически производить замену пароля или ключа закрытых файлов .
Для этого откройте закрытый файл старым ключом и паролем.
Закройте полученный файл новым паролем и ключом.